Rapid Dev _ Problem with 6.8.2 NestData

1
Dear Colleagues, I am new to the Mendix field and am currently running the Rapid Dev training course. So far everything has been going very well. Unfortunately I currently have a problem in point 6.8.2. There I am linked in sub-item 2 to fill the attributes with parameters. Maybe someone can help me. Greetings Heiko
asked
4 answers
2

Let me see if I can help.

To drop the building block in the right place, it should be showing like below right before you drop it, ie under and inside the [TrainingEvent, page parameter] box:

 

To change the caption, you double click the bold title showing as selected below (mine already has the correct caption because I’m looking at my finished app) and click the Edit button:

 

If I understood well, your issue comes in the next step, when you start typing “Registration for the” and want to use the two parameters “TrainingEvent_Course/Course/Title” and “StartDate”.

If you don’t have anything in the parameters section, you should be able to add them by clicking New and then Select:

Then, you’ll need to expand the different menus/folders to find the right attributes and select the one you want (that will be {1}) and then click Select. Then do the same for {2}.

Alternatively, you can also just start typing the names in search box, which is faster.

Make sure the Caption is correct, ie mentioning the course title first and then the start date.

 

Hope this helps!

Do let me know if you were able to solve the issue with these steps!

If not, we’ll keep digging :)

answered
1

---Edited, following your update----

Hi Heiko!

Module 6.8.2 – Nest Data (here) says:

Jumping to your question on the attributes:

- to be able to refer to the Atributes ({Course Title} and {StartDate}), you may need to add them below, in the Parameters section. Just click New and find the CourseTitle and repeat for the StartDate.

- if they are already showing, just refer to them using the correct undex (1 or 2)

- the Caption should now show what you see on the screenshot of the course steps, ie Registrations for {1} on {2}

 

If this is not working, it could be that the building block was not placed in the data view section of the page. 

When you misplace the building block, it will show an Error when you try to edit the Parameters:

If this is the error you’re getting, make sure you are dropping the building block in the data view and not inside another section or container.

Hope this helps!

 

answered
1

Hello Ana,

thx for your answer.

yes exactly. Your screenshot shows my problem. Obviously I have a big knot in my head to understand that I need to put the block in the data view and not in another section or container.

I write e.g. "Register {1}" in the caption.

Where can I find the data view to define {1} with a value?

Do you have a screenshot for that, please?

thx heiko

answered
0

Hi Stijn,

It is not possible for me to enter these parameters (marked red area).

answered