Rapid Application Development Module 6.8.2 Error Help

0
Hey all, I have finished module 6 on this course however I am getting two outputs errors despite following the instructions correctly. I have seen others on the forums have also had this issue as seen here https://forum.mendixcloud.com/link/questions/100848 I am getting the errors:   I have seen people mention changing the navigation visibility settings. I then allow the Administrator and User role access as they do with each of the other created pages (However I never set this access so why are only these two pages not allowed access by default?)   Following that however I now get a cluster of 16 different error messages (8 for each role):   Can someone help me identify where I have missed on the training module, and how to correct this? Thanks in advance.
asked
2 answers
2

Hi Matt,

I haven’t done this training path recently so can’t point you to the spot where the training may be incomplete, however, those errors are related to permissions on entities in your domain model.  If you open the properties window for each of the listed entities, click on the Access rules tab and grant access to all attributes and associations for user role Administrator, the errors should be resolved.

Hope that helps,

Mike

answered
1

I've followed module 6 as well but am not getting similar errors as Security is turned off in the downloaded app package:

 

Is it possible that you've turned on security at some point? I know you've already solved the issue, but that would also explain how it happened in the first place :-)

answered