Implementation of deeplink with SAML SSO

0
after login not able to the redirect to particular page its showing default home page. I have implemented all thing according to the documentation still its not working  
asked
2 answers
1

Few things:

  1. Have you ensured that the navigation home page calls the DeepLinkHome microflow?
  2. Have you given appropriate permissions your user role and added the Deeplink.User module role?

 

If these are correctly configured, you could debug and see where exactly it goes wrong and post further if you can’t make it work.

answered
1

Did you do this part of the documentation:
 

    SSOHandlerLocation – When a deep link is configured to support anonymous users, the SSO handler is requested before redirecting users to the destination
        The SSO handler will only be requested when the user session is an anonymous user session (this is useful in situations where the SSO handler does not ask users for authentication to support anonymous users)
        When the SSO handler location ends with = (for example, in the case of Mendix SSO: /openid/login?continuation=), the original deep link location will be appended to the SSO handler location

When using the Deep Link module together with the SAML module for SSO in Mendix 9 and above, you might get stuck in an endless redirect loop. This is because the default value for SameSite cookies is "Strict", and the session cookies cannot be forwarded. To avoid this issue, make sure your IdP (identity provider) and your app are in the same domain, and thus on the same site. For example, if your app is on app.domain.com and you open the deep link app.domain.com/link/test, then you are redirected to your IdP to sign in on idp.domain.com/SSO. After you sign in successfully, you are sent back to app.domain.com/SSO/assertion. Finally, you are forwarded to app.domain.com/link/test. Since your requests always stay on the same site, the cookie can be forwarded each time. If it is not an option to have the IdP and the app in the same domain, set the value for the SameSite cookies to "None" or"Lax" to solve the problem. See also Runtime Customization.

Regards,

Ronald

 

answered