Mendix Modeler Issue while saving the app

4
I’m trying to save and run the app to see if everything is implemented correctly I didn’t have any issues yesterday and I haven’t made any major changes but now I’m getting the error below. Can someone help me understand what the issues is? Thanks!   Error: System.ArgumentException: Type 'Mendix.Modeler.Core.ModuleSettings' is not a registered type    at Mendix.Modeler.Common.DocumentTypeRegistry.GetInner(Type type) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Core\Common\Model\DocumentTypeRegistry.cs:line 82    at Mendix.Modeler.Deployment.Local.Optimizations.ModelSnapshot.CalculateChanges(IProject project, IProgressInfo info) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Deployment\Local\Optimizations\ModelSnapshot.cs:line 73    at System.Linq.Enumerable.All[TSource](IEnumerable`1 source, Func`2 predicate)    at Mendix.Modeler.Deployment.Build.CoreDeploymentWorker.IsProjectJarUpToDate() in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Deployment\Build\CoreDeploymentWorker.cs:line 80    at Mendix.Modeler.Deployment.Build.CoreDeploymentWorker.DoWork(DeploymentPhase phase, IProject project, DeploymentSettings settings, IProgressInfo info) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Deployment\Build\CoreDeploymentWorker.cs:line 53    at Mendix.Modeler.Deployment.DeploymentProcessBuilder.<>c__DisplayClass13_1.<AddBuildStepsForPhase>b__1() in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Core\Deployment\DeploymentProcessBuilder.cs:line 138    at Mendix.Modeler.ProtectedModules.ProtectedModulesUnlocker.<>c__DisplayClass2_0.<Do>b__0() in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Core\ProtectedModules\ProtectedModulesUnlocker.cs:line 23    at Mendix.Modeler.ProtectedModules.ProtectedModulesUnlocker.ExecuteInContext[T](Boolean unlockImplementation, Func`1 code) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Core\ProtectedModules\ProtectedModulesUnlocker.cs:line 42    at Mendix.Modeler.Deployment.FileIOExceptionHandlingProcess.CatchDiskException(Action action) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Core\Deployment\FileIOExceptionHandlingProcess.cs:line 28    at Mendix.Modeler.Deployment.FileIOExceptionHandlingProcess.<>c__DisplayClass1_0.<AddStep>b__0(IProgressInfo info) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Core\Deployment\FileIOExceptionHandlingProcess.cs:line 19    at Mendix.Modeler.UIFramework.Progress.ProcessRunner.RunStep(Step step) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.UIFramework\Progress\ProcessRunner.cs:line 101    at Mendix.Modeler.UIFramework.Progress.ProcessRunner.OnDoWork(Object sender, DoWorkEventArgs e) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.UIFramework\Progress\ProcessRunner.cs:line 74    at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)    at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
asked
1 answers
8

Did you try to clean the deployment directory and re-run again? Sometimes it helps.

answered