Native app build in Mendix 8.18.8 doesnt start after model / runtime upgrade and server release to Mendix 9.7.0

3
old native app with a new upgraded server doesn't work After a successful migration to mx9 and a deployment on the test environment  the last Native app build (that was build in mx 8.18.8 and is available in the stores at the moment for our users) will not start... We get an error directly after the splash screen and the app is not loading. When I debug it with android I get this error:   I/zygote ( 5065): Rejecting re-init on previously-failed class java.lang.Class<uJ>: java.lang.NoClassDefFoundError: Failed resolution of: Landroid/webkit/TracingController; I/zygote ( 5065): at java.lang.Class java.lang.Class.classForName(java.lang.String, boolean, java.lang.ClassLoader) (Class.java:-2) I/zygote ( 5065): at java.lang.Class java.lang.Class.forName(java.lang.String, boolean, java.lang.ClassLoader) (Class.java:453) I/zygote ( 5065): at java.lang.Class android.webkit.WebViewFactory.getWebViewProviderClass(java.lang.ClassLoader) (WebViewFactory.java:128) Is it at all possible to get a earlier app build (build with Mx8) to work with a server that already has Mendix 9.7.0? The over the air updates option is still disabled. To enable this option we need to make a new build and that is just the thing we don’t want at the moment because then we need to alert all our users.  
asked
2 answers
0

You need to keep the app and Mendix backend in sync. Small updates on the Mendix node, where the native app logic and entities used in the native app are not changed, will work. Anything larger requires a new build. In this case, the Mendix runtime but also for Mendix 9, a lot has been changed in the native modules like nanoflow commons and native mobile resources. You will need to update your appstore app to get it to work again. Please note that currently turning on OTA will break local development. Mendix is working on that one. So best to build a new app, with OTA turned off, allow it to update the native template and then publish it to the stores. For the next major Mendix upgrade, be advised to plan the native app release accordingly.

answered
0

@marcel do you think it is possible to make a intermediate (‘tussen’) version / build that is compatible with both versions of the server (runtime mx8.18 and mendix 9) ? 

in this way, our users have as little inconvenience as possible … 

answered