file path too long error

0
Hi  I attempted to use the Summerhill_Hospital_9_1_1_v2_Module6 app package for the training path “Crash course”. However when importing I get a “File path too long error” – so I assume that either the package contains very long names or I need to use a different local folder. So how do I change the default folder used in Studio Pro? Or is the package error prone?
asked
3 answers
1

Are you attempting to use the package from within many nested folders, maybe with long filenames?

Are you able to move the package nearer the root of a drive like C: and then see if the problem still happens?
 

answered
1

This is common issue when using Dropbox/Box/OneDrive or another backup tool to synchronise your local folders since it prefixes large file paths.  

As Robert suggests the best solution is to store all your Mendix projects at C:\Mendix. 

Open Studio Pro > Open App > Locally from Disk > Select your .mpk > New Team Server > Specify the new project directory e.g. “C:\Mendix\Summerhill_Hospital_9_1_1_v2_Module6-main”

From this point onwards all newly created projects from v9.1.1 will default to C:\Mendix as your Mendix directory. 

answered
0

I tried several options to use the package from also very short file paths

So the problem is the default Mendix folder where it unzips the package into – during this process some files cannot be extracted due to too long files paths.

Hence I assume that I need to change the Mendix folder – which I do not know how to do?

Or the package itself contains very long file paths and hence makes it difficult to unzip

answered