React Error in native build

0
Hi! After working for a while on a native app, I suddenly get this error when I try to view the app via Make It Native 9. I did not even change anything significant, just added a breakpoint and all of a sudden this is in my deployment/native_packager_log:   [Output] error: Error: While trying to resolve module `react-native-view-shot` from file `C:\...\Mendix\TestApp-main_2\deployment\native\widgets\com\mendix\widget\native\feedback\Feedback.android.js`, the package `C:\...Mendix\TestApp-main_2\deployment\native\widgets\node_modules\react-native-view-shot\package.json` was successfully found. However, this package itself specifies a `main` module field that could not be resolved (`C:\...Mendix\TestApp-main_2\deployment\native\widgets\node_modules\react-native-view-shot\src\index.js`. Indeed, none of these files exist: [Output]   * C:\...Mendix\TestApp-main_2\deployment\native\widgets\node_modules\react-native-view-shot\src\index.js(.native|.android.js|.native.js|.js|.android.jsx|.native.jsx|.jsx|.android.ts|.native.ts|.ts|.android.tsx|.native.tsx|.tsx|.android.json|.native.json|.json|.android.js_commonjs-exports|.native.js_commonjs-exports|.js_commonjs-exports|.android.js_commonjs-module|.native.js_commonjs-module|.js_commonjs-module) [Output]   * C:\...Mendix\TestApp-main_2\deployment\native\widgets\node_modules\react-native-view-shot\src\index.js\index(.native|.android.js|.native.js|.js|.android.jsx|.native.jsx|.jsx|.android.ts|.native.ts|.ts|.android.tsx|.native.tsx|.tsx|.android.json|.native.json|.json|.android.js_commonjs-exports|.native.js_commonjs-exports|.js_commonjs-exports|.android.js_commonjs-module|.native.js_commonjs-module|.js_commonjs-module) [Output]     at DependencyGraph.resolveDependency (C:\Program Files\Mendix\9.6.0.27784\modeler\tools\node\node_modules\metro\src\node-haste\DependencyGraph.js:437:17)     A similar issue ocurred on a different app too, but with another react module. I didnĀ“t really find anything useful so far on this problem.. (Mendix Studio Pro 9.6.0, Windows 10)   Best Regards
asked
1 answers
0

I sometimes find it necessary to use the App>Clean Deployment Directory feature and restart.  That usually clears these errors

answered