Excelimporter grid layout weight issue in v9.6

0
Hi, Since the removal of autofit and autofill content in rows within layoutgrids, there are issues with importing the Excelimporter marketplace module. Importing it returns errors regarding the weight of columns/rows. Setting everything to default 12 doesn’t seems to fix it as it still errors, returning that it sums up to 11 for some reason. Multiple fields also dissapear because of this. Is there a workaround to maker this work in mendix v9.6? Thanks
asked
5 answers
0

Eson,

I just created a 9.6 app, imported ExcelImporter, ModelReflection and CommunityCommons.  My app doesn’t show any errors (it does show 44 warnings), And I am able to start the app successfully.  Can you share some screenshots of the errors you have?

Thanks,

Mike

answered
0

Hey Mike,

That’s odd. I’ve added two screenshots. As you can see i get the error of the layout which doesn’t exist. After changing the layout to one of our custom ones you can see that all the grid weights have are  -1.

When changing those to default 12 since the autofit isn’t available anymore, you can see that the grids aren’t formatted as it should and there are fields missing. Settings tab of the “Template_Edit” page in this example.

Thanks for the quick response

Eson

answered
0

I installed the latest version, V10.0.2. Oh really? for me it’s not available as you can see in the screenshot. When i change the width to 1, the column totally dissapears off screen. Could this have to do with the type of application i’ve started out with? I used the EventManagement template provided by Mendix itself. This comes with a native and hybrid phone navigation profile

answered
0

That was my thought also. So i redownloaded the module. Changed the layout to the Atlas_Default but i still get that grid ‘bug’

answered
0

Hmm, this fixes the initial 20+ errors regarding the layout used but the column weights issue still occurs.

Resizing everything to size 12 doesn’t do the trick since there are fields which are lost on import because it has to set the size to -1

 

answered