Running of App Failed due to Java compilation error after converting from version 8.18.4 to 9.4.0

0
Hi All, I have converted an app from version 8.18.4 to version 9.4.0. When I am running the app locally in Mendix Studio Pro version 9.4.0 I am getting the below Java Compilation error: Buildfile: C:\Users\Documents\Mendix\NewApp-LocalCopy\deployment\build_core.xml compile:     [javac] Compiling 474 source files to C:\Users\Documents\Mendix\NewApp-LocalCopy\deployment\run\bin     [javac] C:\Users\Documents\Mendix\NewApp-LocalCopy\javasource\communitycommons\Misc.java:595: warning: [dep-ann] deprecated item is not annotated with @Deprecated     [javac]     public static boolean objectsAreEqual(Object left, Object right) {     [javac]                           ^     [javac] C:\Users\Documents\Mendix\NewApp-LocalCopy\javasource\ldap\actions\ImportLdapGroups_Group.java:46: error: cannot find symbol     [javac]             Result result = ImportUserRecord.runImportGroupsByGroup(this.LdapServerParameter1);     [javac]                                                                         ^     [javac]   symbol: variable LdapServerParameter1     [javac] C:\Users\Documents\Mendix\NewApp-LocalCopy\javasource\ldap\actions\ImportLdapGroups_Path.java:44: error: cannot find symbol     [javac]             Result result = ImportUserRecord.runImportGroups(this.LdapServerParameter1);     [javac]                                                                  ^     [javac]   symbol: variable LdapServerParameter1     [javac] Note: Some input files use or override a deprecated API.     [javac] Note: Recompile with -Xlint:deprecation for details.     [javac] Note: C:\Users\Documents\Mendix\NewApp-LocalCopy\javasource\saml20\implementation\common\MendixUtils.java uses unchecked or unsafe operations.     [javac] Note: Recompile with -Xlint:unchecked for details.     [javac] 2 errors     [javac] 1 warning BUILD FAILED C:\Users\Documents\Mendix\NewApp-LocalCopy\deployment\build_core.xml:29: Compile failed; see the compiler error output for details. Total time: 48 seconds   So if anyone can help on how I can solve this error so that the app can run successfully in version 9.4.0  Thank You.  
asked
1 answers
0

In the LDAP module, you have a Java Action called ImportLdapGroups_Path. This is expecting a parameter called LdapServerParameter1, but that isn’t specified in the action. The solution would be to rename the parameter so the Java code and the action both match.

I did notice on the Marketplace that this module is marked as deprecated by Mendix, so it may be worth looking at an alternative module.

https://marketplace.mendix.com/link/component/24

Hope this helps.

answered