Message to update app to work with iOS 15

1
Hey all, We have a native app and one of my users just upgraded is phone to iOS 15. Since this upgrade he is now seeing an error message that says: “App Needs to be Updated – The developer of this app needs to update it to work with this version of iOS”. He’s unable to open/run the app. I thought that Mendix apps worked across iOS versions. Anyone know anything about this error message? Andy
asked
7 answers
1

Did you also manually update the Xcode version in your build configuration in Appcenter?

 

answered
4

Hey Andrew, the fix is to update your native template and if you use appcenter for your builds to manually select Xcode version 12.5.1

After that create and release a new build

answered
1

Thanks Lennart – I had the assumption that Mendix apps can work across iOS versions – is it normal to have to rebuild the app each time a new iOS version comes out?

answered
1

Lennart, I’m a bit of a newb – can you also tell me where I can find the native template version I’m using, and how do I upgrade that?

answered
0

I think just today the Native App builder was just updated and changed the app center configuration to use xcode 13 – going to try this.

answered
0

FYI – I’ve rebuilt using the latest native builder that is supposed to work on ios 15 – it does not – I’ll need to open a ticket with mdx support. 

answered
0

Thanks Lennart! – this fixed my issue

answered