Java error in SAML module

2
Hi all, I run into this error when I try to run my app. ….javasource\saml20\implementation\DelegatedAuthenticationHandler.java:305: error: cannot find symbol     [javac]             httpPost.setProtocolVersion(HttpVersion.HTTP_1_1);     [javac]                     ^     [javac]   symbol:   method setProtocolVersion(HttpVersion)     [javac]   location: variable httpPost of type HttpPost     [javac] Note: Some input files use or override a deprecated API.     [javac] Note: Recompile with -Xlint:deprecation for details. I cleaned the userlibs, re-imported all the modules but without success. I found this post (https://forum.mendix.com/link/questions/108258) where they have the same issue, but I did not find exactly found how to solve this error.  does anyone know how to solve this problem? Cheers, Jacob   edit: list of userlibs for http.
asked
2 answers
0

Double check your Jar files in the userlib. Do you have multiple httpcore or httpclient Jar files?

Regards,

Ronald

 

answered
0

What I know is, sometimes with java actions Mendix change the variable names by itself, thus leaving us with these kind of compilation errors. I have experienced this with custom java actions. But it is strange that you have it for SAML module.

https://stackoverflow.com/questions/25706216/what-does-a-cannot-find-symbol-or-cannot-resolve-symbol-error-mean

This means, DelegatedAuthenticationHandler.java within SAML module has httpPost attribute created for a class. But probably renamed to something and all the references could still be httpPost. 

If it is possible to open the java file and find this (look in line number 305) try renaming it manually, save the file and run the Mendix application.

See if this fixes the issue.

Also check if there are any latest version with proper fixes for the same

answered