MX 9.5.0 Upgrade error from MX 8.18.8: The type cache does not contain a type with qualified name WebServices$ProvidedService

1
Some long time ago I built an application in MX7 which we upgraded into MX8 and used it for the past two years. Today I am upgrading it from 8.18.8 to 9.5.0. When I open the 8.18.8 project in 9.5.0 Studio Pro, I am receiving the below error. How do I resolve it?   Mendix.Modeler.Storage.Caches.TypeCacheUnknownTypeException: The type cache does not contain a type with qualified name WebServices$ProvidedService.    at Mendix.Modeler.Storage.Caches.TypeCache.GetCachedType(String qualifiedName) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Storage\Caches\TypeCache.cs:line 158    at Mendix.Modeler.Storage.Operations.UnitContentsLoader.ConstructObjectInternal(IStorageUnit containingUnit, IStorageObject container, JObject jObject) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Storage\Operations\UnitContentsLoader.cs:line 55    at Mendix.Modeler.Storage.Operations.UnitContentsLoader.ConstructUnitFromContents(IStorageUnit container, Byte[] contents) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Storage\Operations\UnitContentsLoader.cs:line 39    at Mendix.Modeler.Storage.Operations.UnitLoader.ConstructUnit(IStorageUnit container, DbDataReader reader) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Storage\Operations\UnitLoader.cs:line 233    at Mendix.Modeler.Storage.Operations.UnitLoader.LoadUnits(IStorageUnit unit, IList`1 unitIDs) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Storage\Operations\UnitLoader.cs:line 189    at Mendix.Modeler.Storage.Operations.UnitLoader.LoadChildUnits(IStorageUnit unit) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Storage\Operations\UnitLoader.cs:line 131    at Mendix.Modeler.Storage.Operations.UnitLoader.LoadChildUnits(IStorageUnit unit) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Storage\Operations\UnitLoader.cs:line 158    at Mendix.Modeler.Storage.Operations.UnitLoader.LoadChildUnits(IStorageUnit unit) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Storage\Operations\UnitLoader.cs:line 158    at Mendix.Modeler.Storage.Operations.UnitLoader.LoadChildUnits(IStorageUnit unit) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Storage\Operations\UnitLoader.cs:line 158    at Mendix.Modeler.Storage.Operations.UnitLoader.Load[T](IProgressInfo info, Dictionary`2 _knownUnits) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Storage\Operations\UnitLoader.cs:line 48    at Mendix.Modeler.Operations.ProjectFileLoader.<>c__DisplayClass0_0.<Load>b__0(Database database) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Core\Operations\ProjectFileLoader.cs:line 23    at Mendix.Modeler.Utility.DbConnectors.DbConnector.WithoutTransactionDo[TResult](Func`1 action) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Storage\DbConnectors\DbConnector.cs:line 65    at Mendix.Modeler.Utility.DbConnectors.SQLiteConnector.Do[TResult](String filePath, Boolean useTransaction, Func`2 action) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Storage\DbConnectors\SQLiteConnector.cs:line 0    at Mendix.Modeler.Storage.Database.Do[TResult](String filePath, Boolean useTransaction, Func`2 action) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Storage\Database.cs:line 0    at Mendix.Modeler.Operations.ProjectFileLoader.Load(IProgressInfo info, String filePath, Boolean debugLogEnabled) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Core\Operations\ProjectFileLoader.cs:line 19
asked
4 answers
2

The message indicates that you have a published app service in your app. Those are not supported in Studio Pro 9.

Do you see a deprecation warning when you open the project in Studio Pro 8?

answered
0

While there is no accepted answer here, there are some suggestions in the comments that you might want to try (including custom colors on app services):

https://forum.mendix.com/link/questions/105907

answered
0

I'm facing same issue and asking it to Mendix Support now.

answered
0

If you app uses app services, you should remove them before upgrading as app services are deprecated in Mendix 9. You should also fix any depreciation warnings you see both in development in Studio Pro, as well as in the runtime using your console and browser console. Please see the detail from link: https://docs.mendix.com/refguide/moving-from-8-to-9#3-3-review-your-mendix-8-app
You can find out the deprecated App services used in StudioPro->Errors->Deprecations. 

answered