versions of native code and javascript code are out of sync, iOS, OIDC

0
We are getting the below error in iOS if we are using In App view for OIDC authentication in mobile native solution. WIdget used:  https://marketplace.mendix.com/link/component/117529 Application type: Mendix Native Platform: iOS Widget version: 2.2.0 Mendix Studio Pro Versions: 9.2.0,9.4.0, 9.5.0
asked
1 answers
2

I had this problem as well in Mendix 9, and am planning to address it in a new release soon. In the meantime:

  • Find the file /javascriptsource/OIDC/actions/JS_OpenAuthURL.json
  • Change the version number to 3.6.3
  • in the same folder, use the command prompt to run “npm install react-native-inappbrowser-reborn”

 

After that, you’ll want to build a new developer and distribution app.

answered