Mendix Java Action Debug

0
I have Mendix 9.4 application based java action, my Eclipse version is 2021-06 which is using the bundled JRE. When I try to debug my java action I get the following error:  Incompatible java version: 16.0.2, jvm name: OpenJDK 64-Bit Server VM, Java 11 is required. Note: I have installed other version of JRE, patched the path in eclipse multiple times on multiple versions still getting same result except when I downloaded java 11, patched its path to eclipse, then I am able to launch debugger in eclipse. Is there any place other than eclipse.ini, Mendix is looking for java version? Thanking in advance for support & Input. Pls bear I have selected wrong Mendix Stu Ver in dropdown as my version is not listed.
asked
5 answers
1

 as shown  in mendix System Requirements you should use jdk 11

https://docs.mendix.com/refguide/system-requirements

 

 

 

 

answered
1

Hi Sakthi vel,

Install the JDK 11 and set the path in environment variables and select workspace default jre Java Build Path.

Added screenshot for your reference.

answered
0

try to change Change Java Version in an Eclipse Project to jdk 11

 https://www.baeldung.com/eclipse-change-java-version

answered
0

Thank you all for your response, Yes with JDK 11 set, I am able to launch the debugger from Eclipse(This one I already tried), my question is cant we use any other java version ?

answered
0

Thanks Gamal,

answered