Mendix upgrade from 7.23.19 to 8.17.1 getting java error while creating the build

0
  Mendix upgrade from 7.23.19 to 8.17.1 getting java error while creating the build    C:\Users\gupta540\AppData\Local\Temp\5cia2132.hu2\javasource\audittrail\log\diff_match_patch.java:1806: warning: [dep-ann] deprecated item is not annotated with @Deprecated     [javac]   public LinkedList<Patch> patch_make(String text1, String text2,     [javac]                            ^     [javac] C:\Users\AppData\Local\Temp\5cia2132.hu2\javasource\audittrail\log\CreateLogObject.java:98: error: method getUser in interface ISession cannot be applied to given types;     [javac]             userObject = context.getSession().getUser().getMendixObject();     [javac]                                              ^     [javac]   required: IContext     [javac]   found: no arguments     [javac]   reason: actual and formal argument lists differ in length     [javac] Note: Some input files use or override a deprecated API.     [javac] Note: Recompile with -Xlint:deprecation for details.     [javac] 1 error     Can anyone please help me on this.   Thank you
asked
3 answers
4

Mendix 8 runs on Java 11, whereas Mendix 7 runs on Java 8. Make sure that your Java actions are compatible with Java 11. The official Java 8 to 11 migration guide can be found in the Migrating From JDK 8 to Later JDK Releases section of the Oracle JDK Migration Guide.

https://docs.mendix.com/refguide8/moving-from-7-to-8#deprecated-apis 

answered
0

Have you followed the instructions outlined here when upgrading from 7 to 8?

 

Moving from Desktop Modeler Version 7 to Studio Pro 8

answered
0

If it’s an App store module, try to download it again to get the last upgraded version and also clean your deployment package after downloading it.

answered