flat file importer does not run the schedule

0
i downlaoded the latest verison for flat file importer from the app store. i did setup few import jobs and i am able to run them successfully and import data when running “Test Execution” so now i try to use the schedule option so that it run every 10 minutes, at first when i enable it it sets a time for it, but it never runs. the time also does not change and last run time is blank. any ideas what i might be doing wrong  ,  i suppose it is to run the job on scheudle , is it not ? ill post some pics of the config down here.
asked
2 answers
0

attached are some pics..

 

answered
0

Found the issue and fixed it.

I had installed the flat file interface on my developing system and it works fine there.

but when i push that to VM’s i saw it was not working. 

Fix is that the Flat File Interface app has couple of scheduled tasks that need to run. I see that it run fine locally on the developing system with those scheduled tasks are active. But on VM when you deploy the package it needs to be enabled in the m2ee.yaml config for this to work.  Below are the changes you need to add to your m2ee.yaml file related to flat file interfaces, after adding these 2 lines and restarting the service, its  working fine now..

 MyScheduledEvents:
  #- SAML20.EnforceTimeoutSession_ScheduledEvent
  - OauthModule.SE_EnforceTimeoutSession_5m
  - FlatFileInterface.SE_ExecuteInterface
  - FlatFileInterface.SE_CleanUpQueues
#  - Module2.Event2
#  - Module3.Event3
 

answered