Native Mobile Nanoflow Issues

0
Hi all, I've recently been having some problems with my native app.   I noticed that some nanoflows are not running anymore. For example, I use the OpenMap Activity and the Take Picture Activity (see screenshots).  I hope someone can help me here. Problem 1) Calling Google maps through OpenMap nothing happens. (android only) The app does not crash and can still be used. Feedback: In the log: Animated: `useNativeDriver` was not specified. This is a required option and must be explicitly set to `true` or `false` (also for iPhone, but app there executes command) ---------  Problem 2) When creating photos (no matter if from library or camera) the app crashes with the following error message. The app has to be restarted.  Feedback: In the log: Animated: `useNativeDriver` was not specified. This is a required option and must be explicitly set to `true` or `false` (also for iPhone, but app there executes command) In Make it Native App:  selectionLimit... (see screenshot below) ---------- App Behaviour iPhone: On the IPhone everything runs stable. Android: A few weeks ago everything worked fine. I haven't made any changes in NFs since then. The app is developed in Mx 9.3.0 and tested in Make it Native 9 app. Thanks a lot,   Marc
asked
2 answers
2

There has been an appstore update

 

**Breaking Change**
Please update your projects NativeMobileResources to the latest to support the new image picker action.

** Improvements**
- Added support for the new image picker action.

answered
0

Hi Lennart, thanks for the tip. In fact, the update worked.  

“Take picture activity” (problem 2) is now fixed.

When calljing the NF the app doesn't crash anymore and works now on Android and iPhone. 
Thanks a lot

 

But the link to google maps viaOpen maps activity” (problem 1) still does not work on android.

answered