Run Locally - Port Error

0
Hi All,  I created an app using the available templates. When I want to run the app in Mendix.Pro, it keeps showing me this error: ”It appears that port 8090 is already in use. Please exit the application that uses that port or change the port number for this application in the server tab of the App settings dialog”. the issue is, the other apps are not open, so don't know what does it mean by “exit the application...”. I also tried to change the port but the same error shows up.  does anybody know how I can solve this issue? Thanks. Paria
asked
5 answers
1

It means some other service is using the port 8090. 

 

  1. Go to Studio Pro, Project Explorer=> Settings =>Configurations Tab
  1. Click  on the default configuration, pop up window will open
  2. Change the Admin port to 8091 or anything else other than 8090

 

answered
0

 

Thanks for the response Shekhar. I tried changing the Port but it still shows me an error:

answered
0

Try changing runtime port to 8081 and admin port to 8091

answered
0

I had the same problem, but it was happening because another Mendix application was still running locally.  I opened that other application in Studio Pro and stopped it.

Before changing port numbers, make sure that no other Mendix application is running locally.

answered
0

When you are running multiple mendix applications from same machine, change the Admin port and Runtime port to a unique number for all the mendix instances. Otherwise, you will have this problem.

Also ensure, you are not running any other local applications in the same port.

answered