SAML module update

0
Hi, I updated one of our application to 7.23.21 and used SAML module version 1.15.3. I had to reconfigure SAML config and enable / toggle active the config, i get exception as below. Any suggestions to fix this, please? Thanks, Vanda
asked
4 answers
0

Hi,

Try to update SAML module to V2.1.2 or latest version and check in the backup application.

answered
0

Did you clean your userlib folder? Because the new module changes a lot of JAR files in the userlib so you might end up with (a lot) of double or obsolete JAR files that needs to be cleaned out. Do also note that the latest module can have issues with AzureAD and Okta setups. See the forum post here: https://forum.mendixcloud.com/link/questions/107477

Regards,

Ronald

answered
0

Not sure if the SAML version 1.15.4 supports OKTA.

answered
0

The error “Assertion Conditions are not met” may be due to an actual mismatch between your app's entity ID (The URI configured under "SP Configuration") and the one that Okta is asserting as the Audience URI.

As far as I can tell, previous versions of the SAML module did not check that the Audience URI matches the SP Id, so if there always was a mismatch in the configuration, it would not have surfaced before upgrading to one of the newer SAML modules.

answered