Unable to login with dministrator account on sandbox

0
Hi there! I need to remove the demo users from the app for obvious reasons, so I now need to authenticate with the administrator account. Obviously, the one I configured in Studio Pro is not deployed to the sandbox (cause I got a message saying that the user/pwdw are wrong), so I created a microflow which create this account, and it’s executed at startup. Everything works fine locally, but on the sandbox, I till got the user/pwd error … Is there any explaination / example somewhere I could use to fix this ? Thanks !
asked
4 answers
1

Is the password you are setting in the ASU not matching the password criteria that you have configured? That would prevent the password from being set.

Also, can't you login with the MxAdmin user?

answered
1

Hi François Lecomte,

In this Scenario I will enable demo users and have only one Demo Administrator Account and login with that in the application running in SandBox and create a new local user and keep it  Administrator role . Again come back to Studio Pro and Disable Demo Users and Click the RunButton which will deploy changes to SandBox Cloud. Now you can use the newly create Administrator Account instead of MxAdmin. 

I hope this wil work for you

answered
0

My experience indeed is that on a sanbox environment the default MxAdmin including password is available unless you change that using the same microflow logic that you just described.

answered
0

Hi François ,

Getting into the sandbox is an undocumented feature. You just use ‘1’ for local running app, you set the administrator password in sprintr.mendix.com for any other environment, but the sandbox… it is just not there. The easiest way is in studio pro opening the App => Security. Set ‘Demo users’ to ‘enable’ and add a demo_admin having Userrole Administrator.

Then deploy your app to the sandbox by clicking ‘Run’, log in using the demo-admin and create some user accounts.

 

answered