Unable to resolve module @react-native-community/netinfo from `./widgets/com/mendix/widget/native/appevents/AppEvents`

1
I have converted Native app from Mendix studio pro 8.15.2 to 9.1.1, while testing and building the app (in make it native 9) I get this error. I ran “yarn add @react-native-community/netinfo” in ./deployment/native/widgets/com/mendix/widget/native path as a temporary fix, but I have to run it every time I deploy the app.  Unable to change the dependencies in ./widgets/com.mendix.widget.native.AppEvents since its a MPK file. Is there a way to update it or add the dependency? Complete log: [Error] error Unable to resolve module @react-native-community/netinfo from C:\workdir\deployment\native\widgets\com\mendix\widget\native\appevents\AppEvents.js: @react-native-community/netinfo could not be found within the project or in these directories: [Error]   ..\..\..\node_modules\@react-native-community [Error] If you are sure the module exists, try these steps: [Error]  1. Clear watchman watches: watchman watch-del-all [Error]  2. Delete node_modules and run yarn install [Error]  3. Reset Metro's cache: yarn start --reset-cache [Error]  4. Remove the cache: rm -rf /tmp/metro-*  Run CLI with --verbose flag for more details. [Output] Error: Unable to resolve module @react-native-community/netinfo from C:\workdir\deployment\native\widgets\com\mendix\widget\native\appevents\AppEvents.js: @react-native-community/netinfo could not be found within the project or in these directories: [Output]   ..\..\..\node_modules\@react-native-community  
asked
2 answers
1

Hi Elice,
i think you have to update dependency for it after after migrating 
https://github.com/aws-amplify/amplify-js/issues/5010
and check out release notes
https://docs.mendix.com/releasenotes/studio-pro/9.1#911
 

answered
0

I’m facing a similar issue. Have you found a solution to this? I’m also on 9.1.1

answered