db restore showing error

0
Hi, I have downloaded db backup from mendix and while restoring it in local system in PostgreSQL 9.6 it is showing following error.   pg_restore: [archiver] unsupported version (1.14) in file header   I have tried to reinstall postgres again and again but still the issue is not resolved. Please help.
asked
3 answers
1

See the link below for details.  I upgraded my local postgres to resolve this.

https://docs.mendix.com/releasenotes/developer-portal/mendix-cloud

answered
0

Hi Sudhansu,
Mendix Cloud database backups are now created with pg_dump version 1.14. This version is shipped with PostgreSQL since October 2019 (PostgreSQL 12, 13). The side-effect is that it is not possible to restore these PostgreSQL backups using a pg_restore version below 1.14 (PostgreSQL <= 11). The error that you will receive is pg_restore: [archiver] unsupported version (1.14) in file header. To resolve this issue, upgrade your software to a version that includes newer versions of pg_dump and pg_restore. Examples are PostgreSQL client version 12 or 13, 
You can download it here 
https://www.postgresql.org/download/
 

answered
0

Hi,

It worked after i upgraded PosgreSQL to latest.

 

Thanks

answered