Upgrading from 8.10.3 to 8.18.5; couldnt migrate legacy files

0
I have recently done a version upgrade on a project – from 8.10.3 to 8.18.5 – and I am getting a warning in the console about some files not being migrated. A quick google of this issue and I couldn’t find anything that already exists (documentation or otherwise) so thought I would ask here to see if anyone else has had/solved this issue. This is a local postgres database and it could be due to not restoring a full test database backup with files included when I initially did the restore. However, I took a full database backup with files, and I can’t even restore this database… this is probably it’s own separate problem though!
asked
1 answers
0

About not able to restore see this release notes: https://docs.mendix.com/releasenotes/developer-portal/mendix-cloud

Mendix Cloud database backups are now created with pg_dump version 1.14. This version is shipped with PostgreSQL since October 2019 (PostgreSQL 12, 13). The side-effect is that it is not possible to restore these PostgreSQL backups using a pg_restore version below 1.14 (PostgreSQL <= 11). The error that you will receive is pg_restore: [archiver] unsupported version (1.14) in file header. To resolve this issue, upgrade your PostgreSQL client software to a version that includes newer versions of pg_dump and pg_restore, for example PostgreSQL 12 or 13.

So try it first with a newer PGAdmin. If you keep those warnings I would suggest filing a support ticket.

Regards,

Ronald

answered