Email tokens are printed as it is in the email

0
have setup email templates module, i am able to send email and receive , except that the tokens that i configured are not showing the correct values it should, instead they are printed as it is.. tokens created as added in the mail body as per below. the replace token section in the microflow has also set to pick up token list , which has 2 tokens in it , based on breakpoint placed just before replacing the token step in the microflow, so the tokens are there,  tokens are found, and then the replace token boolean is set to true and it continues from there. but i dont see the actual values of the token in the email. here is what its gets printed as in the email.  Exception : "{%Excetpion%}" System: "{%System%}" is this the correct format to mention them in the mail body ie  "{%Excetpion%}", or should these be entered as some other format.  
asked
3 answers
1

got this fixed.

It requires you to create an object ( dont commit/refresh)  of the main entity and pull those attribute values( which were created as tokens in the email tempalte) and use that created object as the “data object” on the java token replace. this worked for me , im able to get all the values printed on mail now..  This detail is not mentioned in the documentation. 

 

answered
0

Coincident: I have the exact same issue in an application in which this worked fine upto two days ago. Now, this does no longer replace the tokens, although the tokenlist is retrieved correctly:

In my case the cause was that I had renamed the module that the tokens referred to.

So I had to rerun ModelReflextion to get the correct, new Modulename and its entities.

*Editted*

Have you run mxModelReflection from the adjacent tab:

And have you correctly created the ‘Placeholders’? You should still be able to go to tab ‘Placeholder’ and edit each placeholder and select the attribute again.

Also, I am not 100% certain that the double quotes are handled correctly, so also try without them.

 

answered
0

The token format is fine (prefix: {%, suffix: %}).

I take it you alreadey doublechecked that the tokens you are using in the template are exaclty the same as configured under placeholders of the same template? And that you added the tokens to the plain text body as well, and not only to the HTML body?

Did you already check that the tokens on the plain text body are replaced correctly after Java action ReplaceTemplateTokens has completed?

answered