Current user Account object is empty

0
I have a application where the user logs in with credentials. When i tried to debug the app, I could only see the System “User” object is populated with Name and password, but the Account object does not have the userName/Name but only has the role, Can someone please help. Since Account object is a specialization of User object, why Account object is not populated with UserName ?  
asked
2 answers
1

this depends fully on a few things

  1. is the user also an account or only a User? i.e. MxAdmin is only User and not an account
  2. Are you looking at the current user or another use details, since user details can only be accessed by the user itself (unless the user is an Admin)
  3. How are you debugging? using the microflow debugger? or with logging or page view

 

in other words, to help you we need a bit more information.

answered
0

Hi Rene,

Thank you for your reply. Yes the account I was trying to login in MxAdmin.  Let me explain my requirement.  I have a requirement where 1 logged in user can submit multiple forms, so as soon as the user submits the form, we need to show him the overview page with all the details which the user has submitted, along with the other forms which he has submitted till date. 

I have 1(System.User) to*(ExportRunRequestBody) mapping. Instead of Administration.Account object, I have System.User object is that correct?

Another issue is when i try to do “retrieve” in microflow, the User object does not have the association of ExportRunRequestBody, instead ExportRunRequestBody has association of User object.

How to store all the “ExportRunRequest” objects associated with the User in the database ?  Please help

 

 

 

answered