Native packager error

1
I am getting this error when I run my app locally to test it on ‘make it native 9’. I have been working on the app since morning, and this issue popped up out of nowhere a while ago. My app is error free.. What could be the issue here? Using Mendix Studio Pro 9.0.5. System.AggregateException: One or more errors occurred. ---> Mendix.Modeler.Deployment.Native.UnableToStartNativePackagerException: Unable to start native packager    at Mendix.Modeler.WebUI.Deployment.Native.Packager.NativePackagerManager.<StartServing>d__22.MoveNext() in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.WebUI\Deployment\Native\Packager\NativePackagerManager.cs:line 76    --- End of inner exception stack trace ---    at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)    at System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken)    at Mendix.Modeler.Deployment.Local.LocalRunner.DoLaunchNativePackager() in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Deployment\Local\LocalRunner.cs:line 256    at Mendix.Modeler.Utility.BackgroundUtil.<>c__DisplayClass0_0.<Do>b__0() in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Utility\BackgroundUtil.cs:line 17    at Mendix.Modeler.Utility.BackgroundUtil.<>c__DisplayClass1_0`1.<Do>b__0(Object s, DoWorkEventArgs e) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Utility\BackgroundUtil.cs:line 29    at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)    at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument) ---> (Inner Exception #0) Mendix.Modeler.Deployment.Native.UnableToStartNativePackagerException: Unable to start native packager    at Mendix.Modeler.WebUI.Deployment.Native.Packager.NativePackagerManager.<StartServing>d__22.MoveNext() in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.WebUI\Deployment\Native\Packager\NativePackagerManager.cs:line 76<---  
asked
6 answers
1

Can you try to clean your deployment directory?

answered
0

Experts,

     I am running into the same issue that Ejaz mentioned. Tried cleaning up the deployment directory, but the issue still remains. Appreciate if anyone who was able to get it to working can share their knowledge. 

   

answered
0

Same issue.. 

answered
0

Hello All,

I got the same error today and as suggested above, I just did cleanup deployment directory and then restarted the mendix. My error has gone.

Thank a lot for the suggestion.

answered
0

This error could occur due to many reasons. So I guess best approach would be try troubleshooting steps one by one till the issue is resolved
As suggested above about cleaning deployment directory. It can be done from top Menu in Studio Pro. Click ‘App’ in Mendix 9 and ‘Project’ in Mendix 8. Screenshot is shared for Mendix 9


Other possible things to try are:
I personally experienced this error and for me the only solution which worked is:

Windows Update solved the issue. 
- Check for updates manually

- Download and Install all available updates. Restart when required.
- After restart check for updates again to make sure all updates have been installed
- Reinstall Mendix Studio Pro


Also see previous posts on forum, you will find a few other things like branch names should not contain special characters if you have created branch lines. Please see relevant posts on forum for more info. You can also simply search “native packager” in forum and you will find many 

https://forum.mendixcloud.com/link/questions/104705

https://forum.mendixcloud.com/link/questions/104611

https://forum.mendixcloud.com/link/questions/101555

 

answered
0

Hey, try to delete NativeMobileResources from marketplace module , and download it again 

answered