Mendix 9 Not Compiling SASS?

0
According to the release notes: ”Did we mention that the web stylesheets in themesource are defined with Sass? Because they are! And Studio Pro takes care of the mundane process of compiling them when needed, copying used resources, and correctly caching them without the need of external tools like Calypso.” It doesn’t appear to be compiling for me, though. I’m using a simple test class on some text: .test-class-1{ background-color: green; font-weight: bold; color: white; } If I compile it with Gulp as usual, then it works fine, but if I don’t have Gulp running, then changes are not picked up. I tried Synchronize directory (F4), Rerunning the app, Stop/Starting the app, and restarting Mendix entirely without any success in Mx9 compiling the SASS file by itself. Has anyone been able to get this to work yet?
asked
2 answers
3

Hey David,

 

I was going to link to the documentation… but scanning it myself, I noticed that it doesn’t actually mention this at all:

In order for the scss files from `/themesource` to be compiled, the `settings.json` from your theme needs to be adjusted (this comes out-of-the-box with the new Atlas UI 3.0 starter apps) to include `theme.compiled.css` in the list of `cssFiles`.

 

When `theme.compiled.css` is added to the `cssFiles`, Studio Pro should start compiling all `web/main.scss` files from the `themesource` folders as described in https://docs.mendix.com/howto/front-end/customize-styling-new#styling-output

 

Do note – as this is also not explicitly mentioned in the docs – that the Atlas 2 SCSS files in the `theme` folder are not automatically compiled by this system. It is purely for the new `themesource` modularized system.

 

I’ve internally reported this to the teams responsible for the documentation; so hopefully this will be updated soon there as well 🙂.

answered
0

Any tips & tricks for mendix emulation through parallels? Hot-reload seems to work fine on my windows desktop, but on my macbook through parallels emulations it only updates based on a full mendix reboot. which is not that convenient.

also kinda miss the calypso loophole of porting the 8080 port form the emulation to my mac browser (:1111) might need to update to paralells pro now to directly use the localhost ports of windows

answered