Object reference not set to an instance of an object.

1
I'm currently trying to run my app locally in Mendix Studio Pro, but instead of my app, i get an error: System.NullReferenceException: Object reference not set to an instance of an object.    at Mendix.Modeler.Deployment.CoreMetadataWriter.WriteMetadataProperties(IProject project, JsonWriter writer) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Core\Deployment\CoreMetadataWriter.cs:line 58    at Mendix.Modeler.Deployment.MetadataFileGenerator.GenerateMetadataFile(IProject project) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Core\Deployment\MetadataFileGenerator.cs:line 37    at Mendix.Modeler.Deployment.CoreDeploymentWork.GenerateFiles(IProject project, DeploymentSettings settings, Boolean generateForLocalDeployment) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Core\Deployment\CoreDeploymentWork.cs:line 126    at Mendix.Modeler.Deployment.CoreDeploymentWork.WriteFiles(IProject project, DeploymentSettings settings, IProgressInfo info, Boolean generateForLocalDeployment) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Core\Deployment\CoreDeploymentWork.cs:line 90    at Mendix.Modeler.Deployment.DeploymentProcessBuilder.<>c__DisplayClass12_0.<AddBuildStepsForPhase>b__0(IProgressInfo info) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Core\Deployment\DeploymentProcessBuilder.cs:line 123    at Mendix.Modeler.Deployment.FileIOExceptionHandlingProcess.CatchDiskException(Action action) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Core\Deployment\FileIOExceptionHandlingProcess.cs:line 28    at Mendix.Modeler.Deployment.FileIOExceptionHandlingProcess.<>c__DisplayClass1_0.<AddStep>b__0(IProgressInfo info) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Core\Deployment\FileIOExceptionHandlingProcess.cs:line 19    at Mendix.Modeler.UIFramework.Progress.ProcessRunner.RunStep(Step step) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.UIFramework\Progress\ProcessRunner.cs:line 97    at Mendix.Modeler.UIFramework.Progress.ProcessRunner.OnDoWork(Object sender, DoWorkEventArgs e) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.UIFramework\Progress\ProcessRunner.cs:line 71    at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)    at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)   My Studio Pro version is 8.18.2
asked
1 answers
1

I’ve seen this before if the administrator user role is no longer correctly selected in the project security.

This may happen if security is turned off, while the administrator user role is not selected/no longer exists.

To solve this, set security to either demo/production, and select a user role on the administrator tab. If needed, you can turn security off again and close the dialog.

answered