Progressive Web App (PWA) not creating manifest

0
I'm experimenting in using the PWA functionality in Mendix 9. I'm using 9.0.4 for testing. I released an app with an Online Tablet profile with progessive web-app enabled. However when I inspect the app using lighthouse, it shows that there is no manifest and no serviceworker. (Web app manifest or service worker do not meet the installability requirements. Failure reason: No manifest was fetched) In the Mendix documentation here: https://docs.mendix.com/refguide/progressive-web-app it is stated that the manifest will be auto-generated and placed in the them folder. However in my case this manifest was not created. How do I make the Studio Pro create one for me?
asked
1 answers
1

Hi, I'm using the same version of Mendix Studio Pro and it works well for me. The only important diff may be that I'm using different profile: Phone web offline. Probably the OFFLINE aspect is crucial (although the docs are somehow mysterious about how it works for ONLINE profiles).

https://testmx9pwa-sandbox.mxapps.io/

https://testmx9pwa-sandbox.mxapps.io/manifest.webmanifest?637510757022786320

Tried to set a few props in my theme/manifest-overrides.webmanifest and it did affect the PWA installation, e.g. names and colors have replaced the default values ("Mendix" and white):
            {
              "short_name": "TestMx9PWA",
              "name": "TestMx9PWA: PWA on Mendix 9",
              "background_color": "#99FF99",
              "theme_color": "#FF8000"
            }

The generated manifest.webmanifest:
            {
              "name":"TestMx9PWA: PWA on Mendix 9",
              "short_name":"TestMx9PWA",
              "background_color":"#99FF99",
              "theme_color":"#FF8000",
              "icons":[{...}, {...}],
              "dir":"ltr",
              "start_url":"./",
              "lang":"en-US",
              "display":"standalone"
            }
 

answered