Upgrade from Mendix 6.10.20 to 7.14

0
I have an issue when trying to upgrade my application from 6.10.20 to 7.14 I am getting this error “is not compatible with this version of modeler mendix” when opening with modeler 7.14
asked
3 answers
1

It seems to be the case that Mendix only lets you upgrade to releases that have chronologically appeared after your current version. Mendix 6.10.20 was released on the 26th of August 2020. This means your best bet to upgrade this version to a Mendix 7 version would be to use 7.23.16, which was release the 1st of September 2020. The documentation is lacking in this regard.

 

Be aware that you should upgrade to 7.23.19 or higher, because of the security incident, see the release notes here.

answered
1

Rom is right. You can only upgrade to mx versions that were released chronologically after your current version.
At this point your best option IOP is to try and move back the Mx version manually and hope that nothing breaks. Since most 6.10 versions were bugfixes there is less chance that things break. In any case make a copy of your project files. Then open the mpr with an sqldb tool and change the mx version to a lower number e.g. 6.10.12. https://sqlitebrowser.org/
Then you should be able to upgrade. Good luck

answered
0

There must be something more. Did it reference to a widget or something? Or do you have some custom Java inside? Edit your post with the full stacktrace of the error.

Regards,

Ronald

 

answered