Java compile errors

0
Hello everyone, I am trying to upgrade my app from Mx7.8.0 to 7.23.19. I have also upgraded all my app store modules. After resolving all errors I keep getting this error during compilation: Buildfile: C:\Users\~\Documents\Mendix\Garantie Mobiliteit Tool-main\deployment\build_core.xml compile: [javac] Compiling 164 source files to C:\Users\~\Documents\Mendix\Garantie Mobiliteit Tool-main\deployment\run\bin [javac] C:\Users\~\Documents\Mendix\Garantie Mobiliteit Tool-main\javasource\excelimporter\reader\readers\replication\ExcelValueParser.java:75: error: method does not override or implement a method from a supertype [javac] @Override [javac] ^ [javac] Note: Some input files use or override a deprecated API. [javac] Note: Recompile with -Xlint:deprecation for details. [javac] Note: C:\Users\~\Documents\Mendix\Garantie Mobiliteit Tool-main\javasource\saml20\implementation\common\MendixUtils.java uses unchecked or unsafe operations. [javac] Note: Recompile with -Xlint:unchecked for details. [javac] 1 error BUILD FAILED C:\Users\~\Documents\Mendix\Garantie Mobiliteit Tool-main\deployment\build_core.xml:29: Compile failed; see the compiler error output for details. Total time: 3 seconds This error only seems to occur after updating my app store modules. I've already gone through my userlib folder 3 times and removed every double versioned .jar file. Does someone maybe know how to resolve this problem? Thanks in advance!
asked
1 answers
1

Are you using version 8.2.2 of the ExcelImporter module? The error comes from the Java trying to override functionality in replication.jar, so you want to make sure you only have one version of that in your userlib. I would suggest removing replication.jar and then reinstalling the ExcelImporter module as that should then install the correct version. 

Good luck.

answered