Pluggable widgets missing pluginWidget=true setting

2
Hi all, Since I have many widgets in the AppStore based on the legacy Dojo framework I thought let’s invest some time and rebuild some in the React framework.  Whilst investing my time in rewriting the fairly complex GoogleMapsPolygon widget, I tried to use some examples based on React and from Mendix itself, but it seems many of the more complex widgets Mendix created are not true Pluggable Widgets, but some inbetweener. The code is based on React and TypeScript, but in the widget XML the pluginWidget=true setting is set to false. Documentation on this matter is lacking, but I would like to understand why this is the case. Is there a good reason currently to create a React/TypeScript based widget with pluginWidget not being set to true? Or has Mendix created these because there was a shortcoming in the Pluggable widgets API which is currently resolved (type=dataSource from Mendix 8.7 onwards for instance)?
asked
0 answers