Error while building custom widgets:

0
In crash course module 11.6.1, after writing the npm run build command for my custom widget, I’m getting the following error : 'pluggable-widgets-tools' is not recognized as an internal or external command. operable program or batch file. npm ERR! code 1 npm ERR! path C:\Users\Rachit\Documents\Mendix\Module-11\customWidgets\shiftCalendar npm ERR! command failed npm ERR! command C:\WINDOWS\system32\cmd.exe /d /s /c "pluggable-widgets-tools build:web" How can I fix this issue?
asked
3 answers
0

Did you use the https://www.npmjs.com/package/@mendix/generator-widget Mendix generator widget to scaffold your widget project? It should work if done via the generator. 
You can also try installing the missing ‘pluggable-widget-tools’ using : npm install @mendix/pluggable-widgets-tools

answered
0

Try to run the following command instead of this : npm install @mendix/generator-widget -g  

npm i @mendix/generator-widget@8.13.0 -g

You can refer the following link, whenever you are facing an issue while executing the command to install Mendix Pluggable Widget Generator. Sometimes this issue can be fixed by running the specific versions & can find respected dependencies.

 https://www.npmjs.com/package/@mendix/generator-widget

And also check this link for latest issues, updates etc : https://github.com/mendix/widgets-resources/pulls

answered
0

Mendix has released a new version of this course that no longer has this error.

answered