Mendix Studio Pro dont run on Windows ARM architecture

2
Hi all, I need to install Mendix Studio Pro on Windows 10 based on ARM architecture through parallels Desktop on Mac M1. It seems that Mendix studio pro can’t run on this type of windows 10 structure. Does anyone have an idea for a workaround ? Thanks. 
asked
6 answers
3

Hi All,

Any update on this? I'm interested in the M1 Macbook Pro. I hope someone can tell me if and how MX runs and how it was accomplished.

 

Thanks in advance.

answered
1

Same here, still waiting. 

answered
1

Updated on Jul 7 2021, the latest version of Parallels still doesn't support Mendix, though they have added an instruction on website that the Parallels is now support the mac with M1 chip, that just doesn't work at all!

answered
0

Charles,

The Mendix modeller is x64 based and not ARM64 therefore it will not run on Windows 10 for ARM.

Parallels is working on a new version for M1 and that will be released in the near future. That version will also support Windows x64. See also: https://www.parallels.com/blogs/parallels-desktop-apple-silicon-mac/

In the same post, you see a link to Microsoft, they are working to make x64 applications also on Windows 10 for ARM.

If I have to guess Parallels will be first to be able to run Windows x64, but it could take a while.

For now, there are no shortcuts and no workarounds available. If you want a workstation, you have to get an Intel bases Mac, just a regular PC or get a virtualised Windows machine on Azure. 

answered
0

Hi,

I tried running Mendix Studio Pro on the current Insider Preview Build of Microsoft Windows 10 for ARM inside the beta version of Parallels Desktop. This build supports x86 emulation and, as far as I know, should therefore also be able to emulate the Mendix Studio Pro, shouldn’t it?

Thanks!

answered
0

Hi,

With the official release of new version of Parallels 16.5.0 (today) with its official support for Apple M1 chip built in I regret to inform that it's still not possible to install Mendix 8 or 9 on newest beta version of Windows 10 for ARM.

Versions I've tried:

Mendix 8.18.3

Mendix 9.0.4

Mendix 9.0.5

on Windows 10 Pro OS build 21359.1

I'd love if somebody can prove me wrong and it is possible to run Mendix modeller via this or any other setup on Apple M1, thank you

answered