Image/file uploader not working

0
I’ve looked into similar questions that have been asked in the past but I couldn’t come up with a solution unfortunately. I’m using OpenStreetMaps in my thesis project, and one functionality that I’m working on is uploading images or videos from a specific place on the map. For some reason, when I select the image or video option, the uploader does not allow me to browse through my files and upload a corresponding file. I’ll include some pictures from the domain model and the page I use for these functionalities. Any help is much appreciated!
asked
2 answers
2

Hi, 

Seems like you are showing different data views for a selected file type. What I observe in this is that the file document is either not created or not associated with the Content Object. Please verify if the ContentPhoto or ContentVideo is getting is created, Replicated your scenario it fails only if the object is empty. 

You can easily generalize filedocument with Content entity and store all the files there and yes while retreving you can simply getch based on the content type. It is not necessary to have multiple file document entities unless you need it for any audit or something. Because in base image entity is also a generalization with filedocument. 

answered
2

The Content timestamp, Name and Upload afbeelding seem grey and that suggests only rights to read, not write. Check the Access rules of both entities ContentPhoto and ContentVideo. Also, see if you have better luck if you do not have to deal with the type-option: create a separate page for photo and a separate one for video, just to get the hang of it.

PS. just to rid your thesis of some potential remarks from your professor: 1) make sure you don’t mix english and dutch, 2) for both longitude and latitude: show them with 8 decimals, using only 2 covers an area of several thousand square km 3) on the datetimestamp also show the time.

answered