Scheduled Events Unable to start

0
v´╝ÜMendix Studio Pro 8.14 The scheduled event has been added to my module with an interval of 1 minute. There is a widget for displaying messages in Microflow. After running the project for 1 minute, an error is reported.   java.lang.NullPointerException: null     at com.mendix.modules.debugger.internal.DebuggerJSONGenerator$.addMxObjectProperties(DebuggerJSONGenerator.scala:127)     at com.mendix.modules.debugger.internal.DebuggerJSONGenerator$.$anonfun$createMicroflowVariables$1(DebuggerJSONGenerator.scala:89)     at scala.collection.immutable.Map$Map2.foreach(Map.scala:335)     at com.mendix.modules.debugger.internal.DebuggerJSONGenerator$.createMicroflowVariables(DebuggerJSONGenerator.scala:81)     at com.mendix.modules.debugger.internal.DebuggerJSONGenerator$.createPausedMicroflowObject(DebuggerJSONGenerator.scala:64)     at com.mendix.modules.debugger.internal.DebuggerJSONGenerator$.createEventObject(DebuggerJSONGenerator.scala:38)     at com.mendix.modules.debugger.internal.DebuggerHandler.$anonfun$processJsonRequest$8(DebuggerHandler.scala:129)
asked
2 answers
1

Hi Yl Wang,
Please use the English language to communicate with the Mendix Community. I translated your question as follows:

Version: Mendix Studio Pro 8.14

The scheduled event has been added to my module with an interval of 1 minute. There is a widget for displaying messages in Microflow.
After running the project for 1 minute, an error is reported.

As I don't see any error on your shared screens, I'm a bit guessing here; if this doesn't answer your question, please share the error and the expected result.

A scheduled event runs on the server, also if no client is logged on. It is sort of “headless”, so your activity to show a warning will not work, because that is “an instruction to the client”. You could use the “Log message” activity to show a log record in the Mendix Console.

Hopefully this helps!

Regards,

Johan

__

Update: now you've added the error screen, I see the error is about the debugger. Could you try to add another activity, like create variable, and put the debugger on that activity? As said, the instruction to client cannot be made, so maybe the debugger crashes specifically on that activity (although it should not).

answered
0

There is a known issue in this version concerning the debugger: https://docs.mendix.com/releasenotes/studio-pro/8.14 

See the very last bullet on that page.

It may be worth migrating to 8.15

I hope this helps.

answered