Cloud deploy users

0
I have deployed my application in mendix default cloud. I have some admin and demo users added in my security. When I tried to login through the credentials it is not working. Is there anything I need to do more ?
asked
1 answers
2

hi, some questions and related answers

  1. Are you deploying to a free tier or a licensed cloud node? => Demo users aren’t enabled here 
  2. Are demo users enabled? => not only adding but also enabling the setting is required
  3. If not using the demo users, but your own demo users =>  development in studio pro and local deployment != cloud runtime & database. You need to create them in the cloud as well

 

//Edit

Some ways to manage user in the cloud 
Note this is for local user management, testing not related when using SSO and is just a simple approach!

  1. Add the default account admin page Account_Overview to your navigation

Local deployment

  1. Login using MxAdmin/1
  2. Navigate to Account page and add local users

 

Cloud

The default MxAdmin isn’t available in a free tier app.

  1. Add a after startup microflow which creates your admin user and assign the Admin role
  2. Deploy app to cloud
  3. Login using your new admin
  4. Navigate to Account page and add local users
    If you want a defined set of demo users, these could be created in the after startup as well. 

 

 

Note On a licensed cloud node the password of the MxAdmin account can be set per environment in the environment settings. And thus MxAdmin can be used as master admin

 

 

 

answered