Class file has wrong version

2
Good Morning, whnever I edit a java action in eclipse, I get this error in Mendix Studio Pro when i try to run the application. After cleaning my deployment directory, everything works fine again. I guess it is some wrong eclipse setting, but this error  is not helpful for me. Does someone have an Idea?
asked
1 answers
4

Mendix Studio pro java requirements are AdoptOpenJDK 11 or Oracle JDK 11

Class version 52 is java 8. You need Java 11. So may be your eclipse is set to JDK 8. 

To probably change the Java version for eclipse

  1. Open eclipse.ini file which should be in users directory
  2. Change the java version and JRE path
  3. Or in eclipse, open windows, browse for java -> compiler change to 11 (if available)

 

See if the below link has some input for you to fix the issue. 

https://stackoverflow.com/questions/28180915/class-file-has-wrong-version-52-0-should-be-50-0#:~:text=It%20means%20your%20Java%20runtime,version%20from%201.8%20to%201.6.

https://www.chiefdelphi.com/t/class-file-has-wrong-version-55-0-should-be-52-0/374988/10

answered