Database configuration

where i have to edit the number of ConnectionPoolingMaxActive , because the below error appears on the production server and stops the service and it seems that this number is limited for 50 only  ERROR - ConnectionBus: Opening JDBC connection to failed with SQLState: null Error code: 0 Message: Cannot get a connection, pool error Timeout waiting for idle object Retrying...(1/4) Do i have to add this ling on the settings.yaml and add a row that contains  ConnectionPoolingMaxActive : 2000 Note : i read the  document on the below link , but i need another way rather than changing the environment variables , is it okay to make changes on the settings.yaml file please help it’s urgent 
2 answers

You should contact Mendix support. I remember when we needed to change that on an application, the Mendix cloud team needed to enable more connections in the backend as well. I don’t know if that is still the case, but just to be sure, it is a good idea to connect Mendix support because of such a change.


You can place these settings on the Runtime Tab of your enviroment. I hope you have enough memory for this amount of connections. Could be, but be aware that you can create another problem.