Chrome - This application requires cookies to be enabled.

6
Since yesterday I get the error message “This application requires cookies to be enabled.” for all my Mendix apps when I try to open them in Chrome: Looks like it is related to this “feature” of Chrome: https://www.chromestatus.com/feature/5633521622188032 If I go to chrome://flags/ and disable “Cookies without SameSite must be secure” it works like before. Where can I set the cookie content for my Mendix apps? Regards Thilo  
asked
5 answers
1

There is some info on it here: https://docs.mendix.com/refguide/custom-settings

Look for “SameSite”.

I am not sure if that will fix the issue for you.

answered
1

Thanks Michiel for this good hint.

Changing com.mendix.core.SameSiteCookies to Strict changes all cookies besides one called “originURI”.

And one cookie with the wrong settings is still too much for Chrome.

answered
1

This websites gives a good explenation: https://web.dev/samesite-cookies-explained/

Regards,

Ronald

 

answered
0

I'm also getting this error when using Safari and Chrome on an IPad when I have an Iframe embedding another Mendix app. I don’t experience the issue when using desktop versions of these browsers. Here’s a link to my post: https://forum.mendix.com/link/questions/101457

I was able to fix it on Safari for IPad by enabling third party cookies, Settings > Safari > un-check Prevent Cross-Site Tracking and un-check Block All Cookies. I was able to implement Thilo’s solution on an IPad but the issue persisted. So far I’ve been unable to find any documentation on how to enable third party cookies on Chrome for IPad.

Setting the SameSite attribute in both the app embedding the Iframe and the app inside the Iframe didn’t fix it either.

I’ve recently been  made aware that a lot of our users do indeed use IPads so I’ll have to figure out a way to get the Iframe working, or come up with a new UX design that’s just as intuitive.

answered
0

This has been solved by Mendix 8.11.1:

https://docs.mendix.com/releasenotes/studio-pro/8.11

Thanks!

answered