Import module - widgets - Mendix Forum

Import module - widgets

13

Hi,

When importing a marketplace module it either overwrites the widget or if you cancel it aborts the import of the module.

It would be very welcome to be able to select which widgets to overwrite based on their version, e.g. per widget provided with the module show:

- Present in current project (yes / no)

- Current version of widget (if present)

- Module version of widget

Provide the option to select with checkboxes which widgets to overwrite with the version from the marketplace module

Provide the option to Select all / Deselect all / Select all widgets with newer version in module.

 

Keeping track of widgets versions and staying up to date is hard enough as it is. From a security perspective it is an additional obstacle to keep your project secure and avoid outdated widgets & libraries.

 

Note: this also applies to importing the other (java) dependencies, please make it easier to see versions and only import newer versions of the dependencies

asked
4 answers

Back here again after having the widgets being overwritten again...

Created

Back here again after having lost most of my Datagrid2  2.5.0 config after importing a Drag and Drop module with 2.0.0 Datagrid 2 widget.

Created

This is much needed especially with the DataWidgets since that particular marketplace module seems to have frequent updates. I find myself having to update the widgets after importing other modules into projects and not knowing which versions are being imported, I opt for having to import the DataWidgets module again to ensure the project stays up to date.

Created

This should definitely have more votes!

Created