Upgrade to OpenAPI 3.0 - Mendix Forum

Upgrade to OpenAPI 3.0

6

Several advantages of using OpenAPI 3.0 over 2.0 (Swagger):

 

Also see this newstuff-overview:

 

Export a published REST-service of your Mendix application to see the current export: Swagger 2.0.

Love this feature.Would love it even more if it generates OpenAPI 3.0

asked
2 answers

@Ronald, the releasenote indicates that the SwaggerUI is upgraded and compatible with OpenAPI 3.0. But it does not mention the swagger.json-export getting the new OpenAPI 3.0 definition. It does however make it more feasible. 

Created

I might be mistaken but it seems Mx8 already generates OpenAPI3.0. See the upcoming release notes here: https://github.com/mendix/docs/pull/1788/files

* We upgraded Swagger UI (used in the interactive documentation of published REST services) from 3.4.3 to 3.22.2.

And according to https://github.com/swagger-api/swagger-ui

Compatibility

The OpenAPI Specification has undergone 5 revisions since initial creation in 2010. Compatibility between Swagger UI and the OpenAPI Specification is as follows:

Swagger UI VersionRelease DateOpenAPI Spec compatibilityNotes3.18.32018-08-032.0, 3.0tag v3.18.3

Regards,

Ronald

 

Created