For better understanding the actions performed by an activity it is crucial that its name matches it actions. In case of 'Rollback Object' there is a mismatch. The term Rollback means reverting all changes to the database and is also implemented as such both in Java and in Mendix Errorhandling, where 'Rollback’ and ‘Custom with Rollback’ also revert the changes that have been committed to the database.
The activity Rollback on the other hand only reverts the changes that have not been committed to the database. Therefor it can better get renamed to 'Revert Uncommitted Changes'.
See https://forum.mendix.com/link/questions/94209 which triggered this idea.